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Instructions: 

1) There are 100 questionsJn this question paper. AU questions are compulsory.

2) Select proper option to make the statement correct.

3) The 0MR sheet is given for answering the questions. The answer of each

. question is represented by (A) 0, (B) 0, (C) 0, (D) 0. Darken the circle • of

the correct answer with ball-pen.

4) Each question carries 1 mark.

- 5) Rough work is to be done on the space provided for this purpose in the Test

Booklet only. 

6) Read the questions carefully before your answer.

7) Set No. of Question Paper printed on the upper-most right side of the Question

Paper is to be written in the column provided in the 0MR sheet.

1) Which step(s) are required to create an object from the class?

(A) Declaration (B) Instantiiation

(C) Initialization (D) All of tll�above

2) Which keyword is used to create an object by allocating memory?

(A) new

(C) allocate
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(B) memory

(D) variable
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3) By which of the following operator, instance variables and instance

methods are accessed via objects?

(A) . operator

(C) * operator 

(B) · ; operator

(D) % operator

4) Which of the following statement is used to declare class variable

totWindows in class with instance variables?

(A) Static Int totWindows; (B) static int totWindows;

(C) STATIC totWindows; (D) Int totWindows;

5) Which variables are not initialized by default values in Java?

(A) Instance variables · (B) Class variables

(C) Local variables (D) All of the above

6) In Java, which is a special kind of method that is invoked when new object

is created?

7) 

8) 

UEG(19) 

(A) Polymorphism

(C) Class

(B) Modifiers

(D) Constructor

Which access modifier in Java provides visibility to classes defined in 

other package also? 

(A) Private

(C) Protected

(B) Public

(D) All of the above

Which of the following keyword is used to refer a superclass constructor 

in subclass constructor? 

(A) super

(C) name of the superclass

(B) extends

(D) new
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9) Which is a variable in Java representing a collection of homogeneous
type of elements?

10) 

11) 

(A) function
(C) for loop

(B) array
(D) while loop .

Which of the following syntax is used to declare array in Java? 
(A) <data type> <array name> [ ]; (B) <data type> [] <array name>;
(C) Both (A) and (B) (D) None of the above

How many bytes of memory location are occupied by an array 'b' of 
int b [] [] = new int [5] [3];? 
(A) 60
(C) 5

){B) 15 

(D) 3

12) What can be considered as a sequence of characters in Java?
(A) null value (B) group
(C) string (D) object

13) Which of the following statement is true to compare the contents of strl
and str2?
(A) strl != str2
(C) strl (=) str2

/ (B) strl = str2 
(D) strl = = str2

14) For which of the tasks, methods are provided by string class in Java?

UEG(l9) 

(A) Compare strings (B) Find length of string
(C) Combining strings (D) All of the above
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15) Which of the following statement is true to return a string with all

characters of strl converted to lower case?

(A) strl .Tolowercase ( )

(C) strl .TOLOWERC ASE ()

'-(B) str 1. toLower Case ( ) 

(D) toLower C ASE ()

16) Date class is available in which of the following Java package?

(A) java.util package (B) java.Date package

(C) java.All package . (D) java.Calendar package 

17) Which information can be extracted by Calendar class of java.util package

of Java?

(A) Year, Month

(C) (A) & (B) both

(B) Hour, Minute

(D) None of the above

18) What does 'length' refer to for an object of String class?

19) 

(A) method

(C) class variable

(B) attribute

(D) class name

Which of the following refers to an error condition in object-oriented 

programming terminology? 

(A) abbreviation

(C) exception

(B) anomaly

(D) deviation

20) Which of the following block handles or takes appropriate action when

an Exception occurs?

UEG(l9) 

(A) catch

(C) throws

(B) try

(D) handles 

· (Space for Rough Work)
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21) Which of the following is an advantage of using a try ... catch block?

(A) Exceptional events are reduced

(B) Exceptional events are eliminated

(C) Exceptional events are integrated with regular events

(D) Exceptional events are isolated from regular events
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22) Which exit code in SciTE editor indicates that the command execution is

successful?

(A) 1
(C) -1

(B) 0
(D) 10

23) Which clause signifies that there is no catch blockwithin the method that

can handle the exception?

(A) if
(C) loop

(B) throws
(D) array

24) Which class in Java is used to accept input from the Keyboard?

· (A) java.util.Input (B) java.keyboard
(C) java.SCANNER (D) java.util.Scanner

25) In which of the following storage type, values are stored in variables are

lost when a computer is shutdown?

(A) Volatile Storage
(C) Both (A) and (B)

(B) Non-Volatile Storage
(D) None of the above

26) How many methods are available in Java for a file class that can ·be used

to perform various operations on a file?

UEG (19) 

(A) 120 (B) 3
(C) 8 · (D) 30
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27) In Linux, "passwd" file present in which directory stores the information
of the users existing in the system?

(A) /root

(C) /etc

(B) /extra

(D) None of the above

28) Which is an abstract representation of an input or output device that is
used as a source or destination for data?

(A) scanner

(C) method

(B) stream

(D) function

29) Which of the following format is used in Java to store a character?

(A) ASCII

(C) Both (A) & (B)

(B) Unicode

(D) None of the above

30) Which class defines the functionality that is available for all character

input streams?

(A) Exact reader class

(C) abstract reader class

(B) void reader class

(D) super reader class

31) Which of the following character is used to m,ark a comment in LaTeX?

w % �) $ 

(C) # (D) &

32) Which of the following website hosts the LaTeX packages?

UEG(19) 

(A) CLAN

(C) CIEN

(B) CTAN

(D) CLEN
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33) Which of the following commands generate the set union _symbol?

(A) \setunion (B) \cup

(C) \cap (D) · \union

C-109

34) Which command is used to view the generated pdf file at the command

prompt?

· (A) show pdffilename

(C) evince pdffilename

(B) view pdffilename

(D) all of the above

. 35) Which menu-option is used in SciTE editor to view the file in the default 

document viewer? 

(A) Insert ➔ Output

(C) . Tools ➔ Go

(B) File➔ Go

(D) Tools ➔ Output

36) What is an optional argument in the following LaTeX command?

\document class [12pt] {article};

(A) article (B) 12pt

(C) document class (D) all of the above

37) What is the full form of tar?

(A) tech archiver (B) tape archiver

(C) test archiver (D) tight archiver

38) Which of the following is a feature-rich media player?

UEG(l9) 

(A) VEC

(C) VLC

(B) VAC

(D) VNC
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39) Which of the following are different variants of Rational Plan?

(A) Singular, Multiple

( C) View, Preview

(B) Single, Multi, Viewer

(D) Server, Client

C-109

40) Which software allows us to make calls over the internet using our

computer?

(A) 'R' software

(C) Skype

(B) Rational Plan

(D) LaTeX

41) Which R command is used for accessing the onlin,e help?

(A) linehelp ()

(C) help ()

(B) on�inehelp ( )

· (D) helpdemo ( )

42) Which of the following is the tag used to implement form element in

IITML?

(A) <form> .... <form> (B) <form> .... </form> 

(C) <lform> .... <lfoim> (D) <frm> .... <lfrm> 

43) Which of the following method sends the data as a block through the
HTTP transaction?

(A) SEf

(C) PUT

. (B). GEf 

(D) POST

44) Which of the following element allows multi-line text input in HTML?

UEG(19) 

(A) input

(C) select and option

{13) textarea 

(D) form
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45) Which of the following is a free open source web development IDE?

(A) Kompozer (B) HTML

(C) Scite (D) Base

C-109

46) In Kompozer, which of the following menu-option is used to view different

toolbars and statusbar?

(A) Edit➔ Show

(C) View ➔ Show/Hide

~ (B) Tools ➔ Show/Hide

(D) Insert ➔ Show

47) Which keyboard shortcut is used to close the site manager pane in

Kompozer?
/ 

(A) F9 (B) Fl

(C) F2 (D) FIO

48) In Kompozer, which of the following menu-option is used to insert label?

(A) Edit➔ Form ➔ Define Label (B) Tools ➔ Define label

(C) Insert➔ Form➔ Define Label (D) File➔ Define Label

49) Which of the following menu-option is used to create selection list option

in Kompozer?

(A) File ➔ Selection List

(C) Insert ➔ List

(B) Edit ➔ Selection List

(D) Form➔ Selection List

SO) Which of the following allows specifying styles for the visual elements 

of the website? 

. (A) Webpage 

(C) Form

UEG(l9) 

(B) Cascading Style Sheets 

· (D) Animation
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51) Which of the following are two main parts of CSS rule?

(A) Select, declaration

(C) Selector, declare

(B) Selector, declaration

(D) Selection, declaration

C-109

52) Which of the following symbol signifies the start and end of a JavaScript

block?

(A) square bracket

(C) curly bracket

(B) semicolon

(D) round bracket

53) Which of the following is a container for storing data in JavaScript?

(A) Integer (B) Variable

(C) Event (D) Event handler

54) In Kompozer, which tabs are available on the right side of CSS Style Sheets

dialog box?

(A) General, Text

(C) Borders, Lists

(B) Background, Box

(D) All of the above

55) Which of the following toolbar contains CSS button in Kompozer?

(A) Format Toolbar - 1 (B) Menu bar

(C) Composition Toolbar (D) Format Toolbar - 2

56) Which of the following company has developed JavaScript scripting

language?

UEG (19) 

(A) Sun Microsystem

(C) Oracle

(B) Microsoft

(D) Netscape

(Space for Rough Work). 
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57) Which built-in function takes the text and displays it in an alert box in-
. JavaScript?

(A) alert ()
( C) message ( )

(B) .display ( )
(D) submit ()

58) In JavaScript, which event occurs when user leaves a page?
(A) unload (B) focus
(C) abort (D) blur

59) . Which of the following is the most important object in the browser object
model?
(A) history
(C) location

(B) document
(D) link

60) Which of the following helps in promoting the business, selling the
products and attracting a large number of customers?
(A) Webpage J(B) Website 
(C) Form (D) CSS

61) Which of the following information should a website contain?
(A) Complete, Irrelevant 'iB) Complete, Relevant 
(C) Incomplete, Irrelevant (D) Incomplete; Relevant

62) Which of the following is the first page that opens when the user enters
the URL address in the address bar of the browser?
(A) Last page
,(C) Web page 

UEG(19). 

$) Home page 
(D) First page
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63) Which menu.:option is used to change color of the text in Kompozer?

(A) Tools ➔ Change Color (B) Insert ➔ Color
(C) View ➔ Color �) Format➔ Text Color 

64) Which menu-option is used to create link in Kompozer?
(A) Edit➔ Link (B) File➔ Link
(C) Tools ➔ Hyperlink (D) Insert ➔ Link

65) Using which of the following inbuilt JavaScript function data can be
converted into number?
(A) parseFloat ( )
(C) parseNumber ()

(B) is number ( ) ·
(D) convertNumber ()

66) Which of the following languages are supported by Aptana studio I DE?
(A) HTML, CSS (B) Ruby, Rails
(C) PHP, Python it)) All of the above 

67) Which website is used to download Blue Griffon HTML editor?

(A) · www.bluegriffon.com

(()) www.griffon.org

(B) www.bluegriffon�org

(D) www.griffon.com

68) Which of the following is a feature of traditional commerce?

(A) Advertising of the product is done electronically

UEG(19) 

(B) Operates within a certain period of time or during business hours

(C) E-payments systems are used for receiving payment

(D) Customer can browse through products and offers
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69) Which of the following is a disadvantage of E-commerce?

(A) Improved Customer Service (B) Privacy

(C) Speed (D.) Conduct business 24x7 

70) Which of the following is a feature of E-commerce?

(A) No sharing of information with competitors

C-109

(B) Operates within a certain period of time or during business hours·

(C) Location renting or purchasing

�
) Advertising of the product is done electronically

71) Which of the following is a popular website for online auction?

(A) www.flipkart.com (B) www.gseb.org

(C) www.ebay.com (D) www.axisbank.com

72) Which of the following statement is true for services provided by Online
Banking?

UEG(l9) 

(i) Customer can check account balance at any time

(ii) Customer can deposit cash using online banking

(iii) _Customer can transfer the money from one account to another

(A) only (i) and (iii)

(C) only (i) and (ii)

(B) only (ii) and (iii)

(D) (i), (ii) and (iii)
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73) Which E-commerce business model refers to business and organisations
that sells products or services to customers over the internet using
websites?

(A) Business to Business (B2B) (B) Business to Consumer (B2C)

(C) · Customer to Customer (C2C) · (D) Government to Business (02B)

74) Which of the following is an example of Business to Business (B2B) model

website?

(A) www.commodity.com

(C) (A) and (B) both

(B) www.tradeindia.com

(D) None of the above

75) Which of the following refers to buying and selling of goods or services

through the use of internet enabled wireless devices?

(A) M-Commerce

(C) M-Banking

(B) Internet

(D) WWW

76) Whi<;:h of the following is the transformation of encrypted text back into

normal text?

(A) Digital Certificate

5) Decryption

(B) Firewall

(D) Viru·s

77) Which of the following is the symbol for trademark?

UEG(l9) 

(A) TM, MS and® (B) TM, MT and©

(C) TM, SM and® (D) TM, SM and©
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78) Which is the most accurate in .determining a mobile device's position?

(A) SSL (B) Website

(C) TCP/IP (D) OPS

79) Which of the following is . used for securing web transactions on the

internet?

(A) IITTP

(C) HTML

(B) TCP/IP

(D) SSL

80) Which is the most popular and widely accepted method of payment on .

internet?

(A) Credit Card

(C) Internet Banking

(B) Debit Card

(D) All of the above

81) Which of the following is provided using encapsulation?

(A) Data protection (B) Data sharing

(C) Separation of data and methods (D) All of the above

82) With which of the following options polymorphism cannot be achieved?

(A) Method Overloading (B) Operator Overloading

(C) Data hiding (D) All of the above

83) An inheritance model refers to which of the following.relationships?

(A) 'is-a' (B) 'has-a' • 

(C) 'a-part-of' (D) all of these

84) Which of the following describes a group of objects with similar attributes

. UEG(19) 

and common behavior?

(A) Class

(C) Program

(B) Object

(D) Diagram

(Space for Rough Work) 
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85) Which of the following is a mechanism of providing protection to data

and methods of a program?

(A) Data abstraction

(C) Polymorphism · · 

(B) Encapsulation

(D) Aggregation

86) Which of the following represents non-exclusive relationship between

two classes?

(A) Aggregation

(C) Inheritance

(B) Composition

(D) All of the above

87) Which of the following is used to distinguish objects from each other?

(A) Attributes (B) State

(C) Behavior (D) All of the above

88) In object-oriented terminology, with reference to Inheritance, existing

class is also called which of the following?

(A) super class (B) parent class

(C) base class (D) all of the above

89) How many primitive data types are supported in Java?

�) 4 �) 2 

(C) 8 (D) 16

90) Java language was developed by which of the following company?

UEG(l9) 

(A) 'Netscape (B) Sun Microsystems

(C) Microsoft (D) Oracle
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91) Which of the following extension file is generated by compiler, when the

program gets compiled without errors in Java?

(A) .C

(C) .org

(B) .Java

(D) .class

92) Single-line comment begins with which sign in Java?

(A) I* (B) II

(C) I** . (D) All of the above 

93) What will be the result of arithmetic expression 9 % 2?

(A) 1

(C) 4

(B) 4.5

(D) 0

94) What is it called when++ operator is used after variable name in Java?

(A) pre increment (B) post increment

(C) increment pre (D) pre decrement

95) Which of the following is used to· repeat a sequence of statements over

and over until some condition occurs?

UEG (19) 

(A) array

(C) · loops

(B) block

(D) boolean

(Space for Rough Work) 
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96) Which statement is executed if the value of boolean expression is true?

97) 

98) 

99) 

if (boolean expression) 

{ 
<statement!> 

} 
else 

{ 
<statement2> 

} 

statement3 

(A) error message (B) statement2

(C) statementl (D) statement3

Which 9f the following statement is used to transfer the control outsid� 

'Switch' or 'Loop' construct? 

(A) else

(C) end

(B) continue

(D) break

Which of the following variable name is not valid.in Java? 

(A) 4subject (B) _marks

(C) total_marks (D) $age

Which of the following defines attributes and methods? 

(A) object (B) class

(C) instance (D) v�iable

100) Which keyword is used in Java to define a class?

UEG(19) 

(A) define (B) DEFINE

(C) class (D) Define

♦ ♦ ♦
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